Sprytne usuwanie pustych kolumn

Puste kolumny znajdujące się pomiędzy właściwymi danymi są szczególnie uciążliwe wówczas, gdy chcemy w arkuszu grupować dane, wykonywać obliczenia lub uruchomić dowolny kreator (np. tabel przestawnych). Jeżeli mamy do usunięcia kilka pustych kolumn, to możemy zaznaczyć każdą z nich i wybrać polecenie Usuń.

Niestety, jeśli kolumn do usunięcia będzie kilkadziesiąt, ta metoda okaże się niezwykle pracochłonna. Proponuję skorzystać z innego szybkiego sposobu. Przyjmijmy, że do arkusza przeniosłeś dane w postaci jak na rysunku.

  • zaznacz komórkę A1 i wpisz następującą formułę: =JEŻELI(CZY.PUSTA(A2);100;NR.KOLUMNY(A2))
  • następnie skopiuj ją do kolejnych komórek po prawej stronie.
Wpisana przez nas formuła sprawdza czy w komórce poniżej znajduje się jakaś wartość. Takie sprawdzenie jest dokonywane dzięki zastosowaniu funkcji CZY.PUSTA. Jeżeli test da w wyniku wartość PRAWDA, wówczas zwracana jest liczba 100. (100 – zostało przeze mnie ustalone, może to być również liczba 500 lub 1000). Jeśli w komórce poniżej znajduje się jakaś wartość, wówczas wynikiem będzie numer kolumny, w której znajduje się sprawdzana komórka. Kolumny zostały ponumerowane i co dalej? Otóż w zestawieniu następnie posortujemy kolumny, a za kryterium przyjmiemy wiersz z numerami. A zatem wszystkie kolumny, które zostały oznaczone numerem 100 (puste), zostaną przeniesione na koniec zestawienia, a wszystkie, które zawierają dane, znajdą się obok siebie.
 
Aby posortować kolumny:
  • zaznacz zakres komórek, które obejmuje całe zestawienie, w naszym przykładzie A1:K20
  • uaktywnij kartę Dane i w grupie poleceń Sortowanie i filtrowanie wskaż Sortuj. W oknie dialogowym, które się pojawiło wybierz przycisk Opcje;
  • W okienku Opcje sortowania, w sekcji Orientacja zaznacz opcję Sortuj od lewej do prawej i zatwierdź ustawienia, klikając OK;
  • z pierwszej rozwijanej listy wybierz pozycję Wiersz 1, zaznacz obok Sortowanie (Wartości) a Kolejność ustaw Od najmniejszych do największych i zatwierdź ustawienia klikając OK.
 
Można zatem przyjąć, że niepotrzebne kolumny zostały usunięte, chociaż jak widać z rysunku w rzeczywistości  nastąpiło jedynie ich przesunięcie. Teraz zostaje nam jedynie usunąć wiersz 1 i mamy przejrzyste zestawienie bez zbędnych kolumn.