Szybsze obliczenia - Suma.Iloczynów

Bardzo często w trakcie przygotowywania raportów i zestawień zachodzi konieczność przemnożenia przez siebie zawartości dwóch kolumn i dokonania podsumowania otrzymanych wyników. Dla przykładu dysponujemy zestawieniem sprzedaży poszczególnych wyrobów. Zawarte są w nim jedynie liczby sztuk i ceny jednostkowe netto.

Aby obliczyć całkowitą sprzedaż, należałoby w pierwszej kolejności wyznaczyć wartość sprzedaży dla każdego wyrobu a dopiero później zsumować uzyskane wartości. Niewielu użytkowników jednak wie, że zadanie to można wykonać za pomocą tylko jednej funkcji - SUMA.ILOCZYNÓW. Przykładowe zestawienie przedstawia poniższy rysunek.

 W celu szybkiego podsumowania sprzedaży:

  • w dowolnej pustej komórce znajdującej się poniżej naszego zestawienia wprowadź następującą formułę: =SUMA.ILOCZYNÓW(B2:B9;C2:C9), która jako argumenty przyjmuje zakresy komórek, które mnoży przez siebie i wyniki sumuje.
 
Powyższe zadanie można równie szybko wykonać za pomocą funkcji tablicowej, która została szerzej opisana w artykule Sprzedaż produktów - zliczona jedną formułą tablicową.