Zliczanie niepowtarzalnych wartości

Ostatnio jeden z czytelników mojego bloga zapytał mnie czy istnieje szybki sposób na zliczenie ilości niepowtarzalnych wartości w danej kolumnie. Oczywiście sposobów jest kilka jednym z nich może być na przykład zastosowanie tabeli przestawnej.

Potrzeba zliczenia niepowtarzalnych wartości w danym zakresie, czasami jest wskazana, aby upewnić się, czy w danej kolumnie rzeczywiście znajdują się powtarzające się rekordy, zanim użyjemy np. narzędzia usuwania duplikatów. W poniższym artykule pokażę, jeden ze sposobów jak za pomocą formuły można bardzo szybko poradzić sobie z tym zagadnieniem. Poniższy rysunek przedstawia zestawienie oddziałów firmy, które są identyfikowane za pomocą Id jednostki.

 

Jeśli chcielibyśmy ustalić ilość unikalnych jednostek w naszym zestawieniu możemy skorzystać z następującej formuły:

  • do dowolnej pustej komórki wpiszmy =SUMA.ILOCZYNÓW(1/LICZ.JEŻELI(A2:A20;A2:A20))

Drogi Czytelniku, jeśli Ty również jesteś pasjonatem Excela, stosujesz ciekawe triki w codziennej pracy, błyskawicznie tworzysz nietypowe formuły i funkcje - zapraszam do dzielenia się swoimi doświadczeniami z innymi użytkownikami na stronie www.excelowo.pl. Zainteresowany - zapraszam do kontaktu.

Pojedyncza osoba może zdziałać niewiele, a wszyscy razem możemy stworzyć coś wielkiego!