Średnia bez wartości zerowych

W programie Excel są dostępne różne sposoby określania wartości średniej zbioru liczb. Na przykład przy użyciu funkcji można obliczać średnie proste i ważone, a także średnie z wykluczeniem określonych wartości. Jeżeli chciałbyś obliczyć średnią z komórek zawierających zera, to stosując funkcję ŚREDNIA, uzyskasz nieprawidłowy wynik. Excel zsumuje po prostu wszystkie wartości i podzieli przez ich liczbę, uwzględniając wartości zerowe. Aby sobie z tym poradzić, należy posłużyć się odpowiednią formułą tablicową.

 

  • wprowadźmy do komórek A2:A11 dowolne wartości łącznie z zerowymi;
  • jeżeli teraz chcesz policzyć średnią wartość liczb z ignorowaniem wartości zerowych wprowadź następującą formułę: =ŚREDNIA(JEŻELI(A2:A11;A2:A11)) a następnie zatwierdź ją wciskając jednocześnie kombinację klawiszy CTRL+SHIFT+ENTER.

Efekt końcowy przedstawia rysunek. Dla sprawdzenie czy faktycznie wyliczona tym sposobem średnia nie uwzględnia wartości zerowych pozwoliłem sobie na wyliczenie obok średniej dostępnej w standardowym zestawie funkcji statystycznych Excela na tych samych wartościach po uprzednim usunięciu zer.