Zliczanie ilości zrealizowanych zleceń

Wyobraźmy sobie sytuację, że prowadzisz rejestr zleceń realizowanych przez firmy zewnętrzne. Szef poprosił Ciebie abyś przesłał dla niego raport, jak przedstawia się ilościowy podział wykonanych zleceń według poszczególnych zleceniobiorców? W pierwszej chwili, mętlik w głowie, tym bardziej, że szef chce bardzo szybko otrzymać zestawienie, jak zwykle "na wczoraj". Przykładowy rejestr zleceń przedstawia rysunek.

 

Aby szybko uporać się z tym zadaniem należy:

  • w pierwszej kolejności musisz uzyskać listę unikatowych firm, które świadczyły dla Ciebie usługi. Pozbycie się z listy powtórzonych wpisów można wykonać przez Filtr zaawansowany lub Tabelę przestawną
  • kolejną informacją, której potrzebujesz jest ustalenie wartości określającej liczbę wystąpień danego zleceniobiorcy. Liczbę wystąpień danej firmy błyskawicznie obliczysz stosując następującą formułę: =LICZ.JEŻELI($B$2:$B$180;F2).

Powyższa formuła w komórce G2 oblicza, ile razy w zestawieniu wystąpiła firma BUENO. Aby policzyć liczbę wystąpień firmy EXPERT w naszym zestawieniu należy do komórki G3 wpisać formułę: =LICZ.JEŻELI($B$2:$B$180;F3) i analogicznie do pozostałych komórek.