Porównanie zawartości dwóch list

Niedawno jedna z czytelniczek mojej witryny, napisała do mnie e-mail z następującą prośbą cytuję: "....Głowię się nad sprawą tak długo, że aż łza z oka pociekła :). Otóż mam w pliku dwie kolumny. Chciałabym, aby adresy e-mail znajdujące się w kolumnie pierwszej zostały usunięte z kolumny drugiej, jeśli się powtarzają. Usuwanie ręczne odpada, gdyż rekordów jest bardzo dużo. Czy Excel jest w stanie poradzić sobie z takim zadaniem? Jest Pan chyba moją ostatnią deską ratunku :)."

Fragment przykładowej listy z adresami e-mail oraz jeden ze sposobów, rozwiązania problemu prezentuje poniższy rysunek.

Aby błyskawicznie porównać bazy adresów e-mail ze sobą i oznaczyć, które adresy e-mail z kolumny A figurują także na liście z kolumny B można skorzystać z następującej formuły:

  • w komórce C2 wprowadź następującą formułę: =JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(B2;$A$2:$A$11;1;0);"brak na 2 liście"), następnie skopiuj do wszystkich komórek poniżej;

W tak oznaczonym zestawieniu kilkoma kliknięciami myszy możesz uzyskać listę powtarzających się adresów e-mail z pierwszej listy. Wystarczy, że skrótem klawiaturowym Ctrl+Shift+L uruchomisz Autofiltr, wskażesz odpowiednie kryterium w kolumnie C i gotowe!

Drogi Czytelniku, jeśli Ty również jesteś pasjonatem Excela, stosujesz ciekawe triki w codziennej pracy, błyskawicznie tworzysz nietypowe formuły i funkcje - gorąco zachęcam do dzielenia się swoimi doświadczeniami z innymi użytkownikami na stronie www.excelowo.pl.

Pojedyncza osoba może zdziałać niewiele, a wszyscy razem możemy stworzyć coś wielkiego!

Transpozycja błyskawiczna zamiana kolumn z wierszami

W dobie tak szybko pędzącego czasu oraz coraz większego natłoku obowiązków, bardzo często zdarzają się sytuacje, że po wprowadzeniu do tabeli dużej ilości danych, nasze zestawienie staje się mało przejrzyste i czytelne. Dochodzimy do wniosku, że lepszym rozwiązaniem byłoby aby dane, które zostały wprowadzone do

Czytaj więcej...