INDEX i PODAJ.POZYCJĘ - wyszukiwanie wartości leżącej na lewo od szukanej

Do wyszukiwania informacji w zestawieniach służy wiele funkcji. Wiąże się to ze zorganizowaniem danych w postaci powiązanych ze sobą wierszy i kolumn. Najbardziej popularna jest funkcja WYSZUKAJ PIONOWO, która ma jedną znaczącą wadę przeszukuje pierwszą (licząc od lewej strony) kolumnę tablicy, aby znaleźć wartość poszukiwaną i podać odpowiednią jej wartość ze wskazaniem innej kolumny.

Problem pojawia się w sytuacji, gdy dane znajdują się po lewej stronie kolumny, w której następuje wyszukiwanie, a my z różnych powodów nie możemy zmienić układu kolumn w źródle danych. Taka sytuacja może mieć miejsce, gdy dane importowane są automatyczne z jakiegoś systemu i mają stale ustalony układ. W celu zilustrowania tego problemu posłużę się tabelą z następującymi kolumnami. Naszym zadaniem jest wyliczenie wartości netto. Aby to zrobić najpierw musimy znaleźć cenę produktu a później wykonać zwykłe mnożenie.


Poniżej zaprezentuję jedno z najbardziej popularnych rozwiązań - na niedogodność funkcji WYSZUKAJ.PIONOWO. Wykorzystam kombinację dwóch innych funkcji: INDEKS oraz PODAJ.POZYCJĘ. Każda z tych funkcji spełnia oczywiście niezależnie jakąś rolę. Ale żeby w pełni skorzystać z ich dobrodziejstw – najlepiej połączyć działanie obu. Aby znaleźć cenę wybranego produktu musimy w komórce F2 wprowadzić następującą formułę: =INDEKS($A$2:$A$11;PODAJ.POZYCJĘ(D2;$B$2:$B$11;0)) zaś potem skopiować do wszystkich poniższych komórek. Efekt końcowy powinien wyglądać jak na poniższym rysunku.

 

Drogi Czytelniku, jeśli Ty również jesteś pasjonatem Excela, stosujesz ciekawe triki w codziennej pracy, błyskawicznie tworzysz nietypowe formuły i funkcje - zapraszam do dzielenia się swoimi doświadczeniami z innymi użytkownikami na stronie www.excelowo.pl.

Pojedyncza osoba może zdziałać niewiele, a wszyscy razem możemy stworzyć coś wielkiego!