Jak sprawdzić płeć właściciela numeru PESEL

Posiadając listę numerów PESEL w swoim zestawieniu bardzo łatwo można określić płeć danej osoby wykorzystując wbudowane funkcje arkuszowe. Płeć identyfikowana jest na podstawie przedostatniej, dziesiątej cyfry w numerze PESEL. Jeśli zatem 10 cyfra jest nieparzysta {1,3,5,7,9} oznacza to, że osoba jest mężczyzną, w przypadku liczb parzystych {0,2,4,6,8} oznacza że osoba jest kobietą. Przykładowe zestawienie danych przedstawia rysunek.

 

A zatem aby w kolumnie C ustalić płeć osoby musimy użyć funkcji JEŻELI. Dodatkowo potrzebne będą również:

  • funkcja MOD do sprawdzenia reszty z dzielenia tej cyfry przez 2 (jeśli wynikiem tej funkcji będzie zero, to liczba ta będzie parzysta, jeśli nie - nieparzysta);
  • funkcja WARTOŚĆ do skonwertowania tego znaku na wartość liczbową;
  • funkcja FRAGMENT.TEKSTU do pobrania z komórki informacji o przedostatniej cyfrze numeru PESEL.

Do komórki C2 należy wpisać następującą formułę: 

=JEŻELI(MOD(WARTOŚĆ(FRAGMENT.TEKSTU(B2;10;1));2)=0;"kobieta";"mężczyzna")

a następnie skopiować formułę do wszystkich pozostałych rekordów, gdzie znajdują się numery PESEL.