Porównanie zawartości dwóch kolumn

Popularnym sposobem na pozyskiwanie nowych odbiorców jest zakup bazy danych z adresami e-mail potencjalnych klientów, do których rozsyłane są później promocyjne oferty. Zanim jednak zajmiemy się rozsyłaniem ofert, proponuję porównanie zakupionej bazy z firmową bazą adresów e-mail.

Zwykle nikt tego nie czyni, lecz od razu przystępuje do rozsyłania ofert, tłumacząc się brakiem czasu na przeglądanie tysięcy adresów. Często takie zbagatelizowanie tematu może prowadzić do nieporozumień. W rzeczywistości jednak nie trzeba poświęcać aż tak dużo czasu jeśli zaprzęgniemy do tego zadania Excela.

Przyjmijmy, że do kolumny A zaimportowałeś bazę adresów e-mail firm z którymi Twoja firma obecnie współpracuje. W kolumnie obok znajdują się baza adresów e-mail, która została zakupiona. Fragment przykładowej tabeli przedstawia rysunek.

Baza adresów e-mail

Aby błyskawicznie porównać bazy adresów e-mail ze sobą i oznaczyć, które adresy e-mail z kolumny B figurują także na liście z kolumny A należy skorzystać z bardzo prostej formuły:

  • w komórce C2 wprowadź następującą formułę: =JEŻELI(LICZ.JEŻELI($A$2:$A$10;B2)=1;"klient obsługiwany";""), następnie skopiuj do wszystkich komórek poniżej;
  • Funkcja LICZ.JEŻELI ma za zadanie sprawdzić, czy w zakresie komórek A2:A10 adres e-mail z komórki B2 występuje 1 raz. Jeśli tak, dzięki zastosowaniu funkcji JEŻELI zwracany jest tekst 'klient obsługiwany'.

Porównanie zawartości dwóch baz adresów e-mail


W tak oznaczonym zestawieniu kilkoma kliknięciami myszy możesz uzyskać listę tylko nieobsługiwanych adresów e-mail potencjalnych klientów. Wystarczy, że uruchomisz Autofiltr, wskażesz odpowiednie kryterium w kolumnie C i gotowe!

Drogi Czytelniku, jeśli Ty również jesteś pasjonatem Excela, stosujesz ciekawe triki w codziennej pracy, błyskawicznie tworzysz nietypowe formuły i funkcje - gorąco zachęcam do dzielenia się swoimi doświadczeniami z innymi użytkownikami na stronie excelowo.pl.

Pojedyncza osoba może zdziałać niewiele, a wszyscy razem możemy stworzyć coś wielkiego!