Udział w obrotach N największych klientów

Analizując dane dotyczące obrotów przedsiębiorstwa często otrzymujemy zadanie, aby obliczyć jaki udział w obrotach stanowią jego najwięksi kontrahenci. Czasem dotyczy to TOP 5 lub TOP 10 największych obsługiwanych odbiorców. 

Przyjmijmy, że w przykładowej tabeli przedstawionej na poniższym rysunku chciałbyś obliczyć w komórce B22 udział pięciu największych wartości sprzedaży w całkowitej wielkości obrotów. Pomoże Ci w tym kombinacja funkcji SUMA oraz MAX.K.

Za pomocą funkcji MAX.K możesz wyznaczyć k-tą największą (w tym przypadku 1, 2, 3, 4 i 5 co do wielkości) wartość sprzedaży w zestawieniu. Dodając te 5 wartości, a następnie otrzymaną wielkość dzieląc przez sumę całkowitą obrotów, wyznaczysz później poszukiwany udział.

W celu obliczenia sumy pięciu największych wartości zakresu B2:B20 wprowadź w komórce B22 następującą formułę:

=SUMA(MAX.K(B2:B20;1);MAX.K(B2:B20;2);MAX.K(B2:B20;3);MAX.K(B2:B20;4);MAX.K(B2:B20;5))

Aby obliczyć teraz udział pięciu największych wartości w całości obrotów, powinieneś otrzymaną wartość podzielić przez sumę wszystkich pozycji. Formuła końcowa przyjmie następującą postać:

=SUMA(MAX.K(B2:B20;1);MAX.K(B2:B20;2);MAX.K(B2:B20;3);MAX.K(B2:B20;4);MAX.K(B2:B20;5))/SUMA(B2:B20)

Jako że Twoim zadaniem jest obliczenie udziału, czyli wartości procentowej, nadaj komórce B22 odpowiednie formatowanie (skrót klawiaturowy Ctrl + Shift + 5). I gotowe!

Drogi Czytelniku, jeśli Ty również jesteś pasjonatem Excela, stosujesz ciekawe triki w codziennej pracy, błyskawicznie tworzysz nietypowe formuły i funkcje - zapraszam do dzielenia się swoim doświadczeniem z innymi użytkownikami na stronie www.excelowo.pl. Zainteresowany - zapraszam do kontaktu.

Pojedyncza osoba może zdziałać niewiele, a wszyscy razem możemy stworzyć coś wielkiego!